Amazon

2013年8月31日土曜日

xen



テスト環境が必要になり、久しぶりにxenを試してみました。


Ubuntuは、パッケージが用意されていて下記ドキュメントもあるので、前ほど苦労せずに設定できそうでした。


https://help.ubuntu.com/community/XenVirtualMachine/XenOnUbuntuEdgy


しかし...


libc6のバージョンは、2.4-1ubuntu12でないとダメと怒られてしまい、あえなく断念しました。



$ sudo aptitude install xen-hypervisor-3.0-i386 xen-image-xen0-2.6.17-6-generic-xen0 xen-utils-3.0 xen-ioemu-3.0
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
Reading state information... 完了
Reading extended state information
Initialising package states... 完了
Building tag database... 完了
The following packages are BROKEN:
libc6-xen
The following NEW packages will be automatically installed:
bridge-utils libxen3.0 python-xen3.0
The following NEW packages will be installed:
bridge-utils libxen3.0 python-xen3.0 xen-hypervisor-3.0-i386 xen-image-xen0-2.6.17-6-generic-xen0 xen-ioemu-3.0
xen-utils-3.0
0 packages upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 23.1MB of archives. After unpacking 69.0MB will be used.
The following packages have unmet dependencies:
libc6-xen: 先行依存: libc6 (= 2.4-1ubuntu12) but 2.4-1ubuntu12.3 is installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
libc6-xen [Not Installed]
xen-ioemu-3.0 [Not Installed]
xen-utils-3.0 [Not Installed]

Score is -37

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.
ksaito@ksaito-desktop$ dpkg -l | grep libc6
ii libc6 2.4-1ubuntu12.3 GNU C Library: Shared libraries
ii libc6-dev 2.4-1ubuntu12.3 GNU C Library: Development Libraries and Hea
ii libc6-i686 2.4-1ubuntu12.3 GNU C Library: Shared libraries [i686 optimi
$





0 件のコメント: